Must be run from the command line